Annotation of embedaddon/coova-chilli/debian/rules, revision 1.1

1.1     ! misho       1: #!/usr/bin/make -f
        !             2: # Sample debian/rules that uses debhelper.
        !             3: # GNU copyright 1997 to 1999 by Joey Hess.
        !             4: 
        !             5: # Uncomment this to turn on verbose mode.
        !             6: #export DH_VERBOSE=1
        !             7: 
        !             8: # This is the debhelper compatibility version to use.
        !             9: export DH_COMPAT=3
        !            10: 
        !            11: # These are used for cross-compiling and for saving the configure script
        !            12: # from having to guess our platform (since we know it already)
        !            13: DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
        !            14: DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
        !            15: 
        !            16: 
        !            17: ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
        !            18:        CFLAGS += -g
        !            19: endif
        !            20: ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
        !            21:        INSTALL_PROGRAM += -s
        !            22: endif
        !            23: 
        !            24: config.status: configure
        !            25:        dh_testdir
        !            26:        # Add here commands to configure the package.
        !            27:        ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info --sysconfdir=/etc --localstatedir=/var
        !            28: 
        !            29: configure:
        !            30:        @test -f configure || ./bootstrap
        !            31: 
        !            32: build: build-stamp
        !            33: 
        !            34: build-stamp:  config.status
        !            35:        dh_testdir
        !            36: 
        !            37:        # Add here commands to compile the package.
        !            38:        $(MAKE)
        !            39: 
        !            40:        touch build-stamp
        !            41: 
        !            42: clean:
        !            43:        dh_testdir
        !            44:        dh_testroot
        !            45:        rm -f build-stamp 
        !            46: 
        !            47:        # Add here commands to clean up after the build process.
        !            48:        -$(MAKE) distclean
        !            49:        -test -r /usr/share/misc/config.sub && \
        !            50:          cp -f /usr/share/misc/config.sub config.sub
        !            51:        -test -r /usr/share/misc/config.guess && \
        !            52:          cp -f /usr/share/misc/config.guess config.guess
        !            53: 
        !            54: 
        !            55:        dh_clean
        !            56: 
        !            57: install: build
        !            58:        dh_testdir
        !            59:        dh_testroot
        !            60:        dh_clean -k
        !            61:        dh_installdirs
        !            62: 
        !            63:        # Add here commands to install the package into debian/chillispot.
        !            64:        $(MAKE) install prefix=$(CURDIR)/debian/coova-chilli/usr sysconfdir=$(CURDIR)/debian/coova-chilli/etc
        !            65: 
        !            66: # Build architecture-independent files here.
        !            67: binary-indep: build install
        !            68: # We have nothing to do by default.
        !            69: 
        !            70: # Build architecture-dependent files here.
        !            71: binary-arch: build install
        !            72:        dh_testdir
        !            73:        dh_testroot
        !            74: #      dh_installdebconf       
        !            75:        dh_installdocs
        !            76:        dh_installexamples
        !            77: #      dh_installmenu
        !            78: #      dh_installlogrotate
        !            79: #      dh_installemacsen
        !            80: #      dh_installpam
        !            81: #      dh_installmime
        !            82:        dh_installinit --name chilli
        !            83: #      dh_installcron
        !            84:        dh_installman
        !            85:        dh_installinfo
        !            86: #      dh_undocumented
        !            87: #      dh_installchangelogs ChangeLog
        !            88:        dh_link
        !            89:        dh_strip
        !            90:        dh_compress
        !            91:        dh_fixperms
        !            92:        dh_makeshlibs
        !            93:        dh_installdeb
        !            94: #      dh_perl
        !            95:        dh_shlibdeps
        !            96:        dh_gencontrol
        !            97:        dh_md5sums
        !            98:        dh_builddeb
        !            99: 
        !           100: binary: binary-indep binary-arch
        !           101: .PHONY: build clean binary-indep binary-arch binary install 

FreeBSD-CVSweb <freebsd-cvsweb@FreeBSD.org>