Annotation of embedaddon/ipsec-tools/rpm/suse/ipsec-tools.spec, revision 1.1

1.1     ! misho       1: #
        !             2: # spec file for package ipsec-tools
        !             3: #
        !             4: # Copyright (c) 2005 SUSE LINUX AG, Nuernberg, Germany.
        !             5: # This file and all modifications and additions to the pristine
        !             6: # package are under the same license as the package itself.
        !             7: #
        !             8: # Please submit bugfixes or comments via http://www.suse.de/feedback/
        !             9: #
        !            10: 
        !            11: # norootforbuild
        !            12: # neededforbuild  kernel-source openssl openssl-devel readline-devel
        !            13: 
        !            14: BuildRequires: aaa_base acl attr bash bind-utils bison bzip2 coreutils cpio cpp cracklib cvs cyrus-sasl db devs diffutils e2fsprogs file filesystem fillup findutils flex gawk gdbm-devel glibc glibc-devel glibc-locale gpm grep groff gzip info insserv less libacl libattr libgcc libselinux libstdc++ libxcrypt libzio m4 make man mktemp module-init-tools ncurses ncurses-devel net-tools netcfg openldap2-client openssl pam pam-modules patch permissions popt procinfo procps psmisc pwdutils rcs readline sed strace syslogd sysvinit tar tcpd texinfo timezone unzip util-linux vim zlib zlib-devel autoconf automake binutils gcc gdbm gettext kernel-source libtool openssl-devel perl readline-devel rpm
        !            15: 
        !            16: Name:         ipsec-tools
        !            17: Version:      0.8.0
        !            18: Release:      0
        !            19: License:      Other License(s), see package, BSD
        !            20: Group:        Productivity/Networking/Security
        !            21: Provides:     racoon
        !            22: PreReq:       %insserv_prereq %fillup_prereq
        !            23: Autoreqprov:  on
        !            24: Summary:      IPsec Utilities
        !            25: Source:       http://prdownloads.sourceforge.net/ipsec-tools/ipsec-tools-%{version}.tar.bz2
        !            26: Source1:      racoon.init
        !            27: Source2:      sysconfig.racoon
        !            28: URL:          http://ipsec-tools.sourceforge.net/
        !            29: Prefix:       /usr
        !            30: BuildRoot:    %{_tmppath}/%{name}-%{version}-build
        !            31: 
        !            32: %description
        !            33: This is the IPsec-Tools package.  This package is needed to really make
        !            34: use of the IPsec functionality in the version 2.5 and 2.6 Linux
        !            35: kernels.  This package builds:
        !            36: 
        !            37: - libipsec, a PFKeyV2 library
        !            38: 
        !            39: - setkey, a program to directly manipulate policies and SAs
        !            40: 
        !            41: - racoon, an IKEv1 keying daemon
        !            42: 
        !            43: These sources can be found at the IPsec-Tools home page at:
        !            44: http://ipsec-tools.sourceforge.net/
        !            45: 
        !            46: 
        !            47: 
        !            48: Authors:
        !            49: --------
        !            50:     Derek Atkins  <derek@ihtfp.com>
        !            51:     Michal Ludvig <mludvig@suse.cz>
        !            52: 
        !            53: %prep
        !            54: %setup
        !            55: 
        !            56: %build
        !            57: %{suse_update_config -f . src/racoon}
        !            58: CFLAGS="$RPM_OPT_FLAGS" \
        !            59: ./configure --prefix=/usr --disable-shared \
        !            60:        --mandir=%{_mandir} --infodir=%{_infodir} --libdir=%{_libdir} \
        !            61:        --libexecdir=%{_libdir} --sysconfdir=/etc/racoon \
        !            62:        --sharedstatedir=/var/run --localstatedir=/var \
        !            63:        --enable-dpd --enable-hybrid --enable-frag
        !            64: make 
        !            65: make check
        !            66: 
        !            67: %install
        !            68: rm -rf $RPM_BUILD_ROOT
        !            69: make install DESTDIR=$RPM_BUILD_ROOT
        !            70: mkdir -p $RPM_BUILD_ROOT/etc/init.d
        !            71: install -m 0755 $RPM_SOURCE_DIR/racoon.init $RPM_BUILD_ROOT/etc/init.d/racoon
        !            72: ln -sf /etc/init.d/racoon $RPM_BUILD_ROOT/usr/sbin/rcracoon
        !            73: mkdir -p $RPM_BUILD_ROOT/var/adm/fillup-templates
        !            74: install -m 644 $RPM_SOURCE_DIR/sysconfig.racoon $RPM_BUILD_ROOT/var/adm/fillup-templates/
        !            75: mkdir -p $RPM_BUILD_ROOT/usr/share/doc/packages/%{name}/
        !            76: cp -rv src/racoon/samples $RPM_BUILD_ROOT/usr/share/doc/packages/%{name}/
        !            77: cp -v src/setkey/sample* $RPM_BUILD_ROOT/usr/share/doc/packages/%{name}/
        !            78: 
        !            79: %post
        !            80: %{fillup_and_insserv racoon}
        !            81: 
        !            82: %postun
        !            83: %{insserv_cleanup}
        !            84: 
        !            85: %clean
        !            86: if test ! -z "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != "/"; then
        !            87:   rm -rf $RPM_BUILD_ROOT
        !            88: fi
        !            89: 
        !            90: %files
        !            91: %defattr(-,root,root)
        !            92: %dir /etc/racoon
        !            93: %config(noreplace) /etc/racoon/psk.txt
        !            94: %config(noreplace) /etc/racoon/racoon.conf
        !            95: %config(noreplace) /etc/racoon/setkey.conf
        !            96: %config /etc/init.d/racoon
        !            97: /usr/sbin/rcracoon
        !            98: %dir /usr/include/libipsec/
        !            99: %doc /usr/share/doc/packages/%{name}/
        !           100: /var/adm/fillup-templates/sysconfig.racoon
        !           101: /usr/include/libipsec/libpfkey.h
        !           102: /usr/%{_lib}/libipsec.a
        !           103: /usr/%{_lib}/libipsec.la
        !           104: /usr/sbin/racoon
        !           105: /usr/sbin/racoonctl
        !           106: /usr/sbin/setkey
        !           107: /usr/sbin/plainrsa-gen
        !           108: %{_mandir}/man*/*
        !           109: 
        !           110: %changelog -n ipsec-tools

FreeBSD-CVSweb <freebsd-cvsweb@FreeBSD.org>