Annotation of embedaddon/lrzsz/debian/rules.in, revision 1.1.1.1
1.1 misho 1: #!/usr/bin/make -f
2: version=@VERSION@
3: package=@PACKAGE@
4:
5: tmpdir = $(shell pwd)/debian/tmp
6: instdirs = $(tmpdir) \
7: $(tmpdir)/DEBIAN \
8: $(tmpdir)/usr/bin \
9: $(tmpdir)/usr/doc/lrzsz \
10: $(tmpdir)/usr/man/man1
11:
12: checkversion:
13: if grep $(version) debian/changelog >/dev/null ; then \
14: : ; else \
15: mv -f debian/changelog debian/changelog.tmp ; \
16: ( echo "$(package) ($(version)) unstable; urgency=low" ; \
17: echo "" ; \
18: echo " * sorry, see ../ChangeLog. automagically generated debian/changelog" ; \
19: echo "" ; \
20: echo " -- Uwe Ohse <uwe@ohse.de> "`date +'%a, %d %b %Y %H:%M:%S +0200'` ; \
21: echo "" ; echo "" ; \
22: cat debian/changelog.tmp ; \
23: ) >debian/changelog ; \
24: rm -f debian/changelog.tmp ; \
25: fi
26:
27: build: checkversion
28: $(checkdir)
29: CFLAGS=-O2 LDFLAGS= ./configure --program-transform-name=s/l// --prefix=/usr
30: $(MAKE)
31: touch build
32:
33: clean:
34: $(checkdir)
35: -rm -f build
36: -$(MAKE) distclean
37: -rm -rf *~ debian/tmp debian/*~ debian/files*
38:
39: binary-indep: checkroot build
40: $(checkdir)
41:
42: binary-arch: checkroot build $(instdirs)
43: dpkg-shlibdeps src/lsz
44: dpkg-gencontrol >debian/tmp/DEBIAN/control
45: $(MAKE) INSTALL_PROGRAM='install -c -s' prefix=$(tmpdir)/usr install
46: install -m 644 debian/copyright $(tmpdir)/usr/doc/$(package)/copyright
47: install -m 644 debian/changelog $(tmpdir)/usr/doc/$(package)/changelog.Debian
48: install -m 644 ChangeLog $(tmpdir)/usr/doc/$(package)/changelog
49: chown -R root.root $(tmpdir)
50: chmod -R g-ws $(tmpdir)
51: dpkg --build $(tmpdir) ..
52:
53: define checkdir
54: test -f debian/rules
55: endef
56:
57: # Below here is fairly generic really
58:
59: binary: binary-indep binary-arch
60:
61: source diff:
62: @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
63:
64: checkroot:
65: $(checkdir)
66: test root = "`whoami`"
67:
68: .PHONY: binary diff clean checkroot zapdirs
69:
70: zapdirs:
71: -rm -rf $(tmpdir)
72:
73: $(instdirs): zapdirs
74: install -d -m 755 $@
75: chmod g-s $@
FreeBSD-CVSweb <freebsd-cvsweb@FreeBSD.org>