Annotation of embedaddon/mrouted/debian/rules, revision 1.1.1.1
1.1 misho 1: #!/usr/bin/make -f
2: # Sample debian/rules that uses debhelper.
3: # GNU copyright 1997 to 1999 by Joey Hess.
4:
5: # Uncomment this to turn on verbose mode.
6: #export DH_VERBOSE=1
7:
8: CFLAGS = -Wall -g
9:
10: ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
11: CFLAGS += -O0
12: else
13: CFLAGS += -O2
14: endif
15: ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
16: INSTALL_PROGRAM += -s
17: endif
18:
19: configure: configure-stamp
20: configure-stamp:
21: @dh_testdir
22: dh_auto_configure
23: @touch $@
24:
25: build: build-stamp
26:
27: build-stamp: configure-stamp
28: @dh_testdir
29: dh_auto_build --parallel
30: @touch $@
31:
32: clean:
33: @dh_testdir
34: dh_auto_clean --parallel
35: dh_clean
36:
37: install: build
38: @dh_testdir
39: dh_testroot
40: dh_prep
41: dh_installdirs
42: dh_auto_install -- prefix=/usr
43: @for file in AUTHORS LICENSE; do \
44: rm debian/mrouted/usr/share/doc/mrouted/$$file; \
45: done
46: @rm debian/mrouted/usr/share/man/man8/map-mbone.8
47: @rm debian/mrouted/usr/sbin/map-mbone
48:
49: # Build architecture-independent files here.
50: binary-indep: build install
51:
52: # Build architecture-dependent files here.
53: binary-arch: build install
54: @dh_testdir
55: dh_testroot
56: dh_installchangelogs
57: dh_installdocs
58: dh_installexamples
59: # dh_install --sourcedir=debian/mrouted
60: dh_installinit
61: dh_installman
62: dh_link
63: dh_strip
64: dh_compress
65: dh_fixperms
66: dh_installdeb
67: dh_shlibdeps
68: dh_gencontrol
69: dh_md5sums
70: dh_builddeb
71:
72: binary: binary-indep binary-arch
73: .PHONY: build clean binary-indep binary-arch binary install configure
FreeBSD-CVSweb <freebsd-cvsweb@FreeBSD.org>