Annotation of embedaddon/php/php5.spec, revision 1.1
1.1 ! misho 1: %define version @VERSION@
! 2: %define so_version 5
! 3: %define release 0
! 4:
! 5: Name: php
! 6: Summary: PHP: Hypertext Preprocessor
! 7: Group: Development/Languages
! 8: Version: %{version}
! 9: Release: %{release}
! 10: Copyright: The PHP license (see "LICENSE" file included in distribution)
! 11: Source: http://www.php.net/get/php-%{version}.tar.gz/from/a/mirror
! 12: Icon: php.gif
! 13: URL: http://www.php.net/
! 14: Packager: PHP Group <group@php.net>
! 15:
! 16: BuildRoot: /var/tmp/php-%{version}
! 17:
! 18: %description
! 19: PHP is an HTML-embedded scripting language. Much of its syntax is
! 20: borrowed from C, Java and Perl with a couple of unique PHP-specific
! 21: features thrown in. The goal of the language is to allow web
! 22: developers to write dynamically generated pages quickly.
! 23:
! 24: %prep
! 25:
! 26: %setup
! 27:
! 28: %build
! 29: set -x
! 30: ./buildconf
! 31: ./configure --prefix=/usr --with-apxs \
! 32: --disable-debug \
! 33: --with-xml=shared \
! 34:
! 35: # figure out configure options options based on what packages are installed
! 36: # to override, use the OVERRIDE_OPTIONS environment variable. To add
! 37: # extra options, use the OPTIONS environment variable.
! 38:
! 39: #test rpm -q MySQL-devel >&/dev/null && OPTIONS="$OPTIONS --with-mysql=shared"
! 40: #test rpm -q solid-devel >&/dev/null && OPTIONS="$OPTIONS --with-solid=shared,/home/solid"
! 41: #test rpm -q postgresql-devel >&/dev/null && OPTIONS="$OPTIONS --with-pgsql=shared"
! 42: test rpm -q expat >&/dev/null && OPTIONS="$OPTIONS --with-xml=shared"
! 43:
! 44: if test "x$OVERRIDE_OPTIONS" = "x"; then
! 45: ./configure --prefix=/usr --with-apxs=$APXS $OPTIONS
! 46: else
! 47: ./configure $OVERRIDE_OPTIONS
! 48: fi
FreeBSD-CVSweb <freebsd-cvsweb@FreeBSD.org>