Annotation of embedaddon/rsync/packaging/lsb/rsync.spec, revision 1.1.1.1

1.1       misho       1: Summary: A fast, versatile, remote (and local) file-copying tool
                      2: Name: rsync
                      3: Version: 3.0.9
                      4: %define fullversion %{version}
                      5: Release: 1
                      6: %define srcdir src
                      7: Group: Applications/Internet
                      8: Source0: http://rsync.samba.org/ftp/rsync/%{srcdir}/rsync-%{fullversion}.tar.gz
                      9: #Source1: http://rsync.samba.org/ftp/rsync/%{srcdir}/rsync-patches-%{fullversion}.tar.gz
                     10: URL: http://rsync.samba.org/
                     11: 
                     12: Prefix: %{_prefix}
                     13: BuildRoot: /var/tmp/%{name}-root
                     14: License: GPL
                     15: 
                     16: %description
                     17: Rsync is a fast and extraordinarily versatile file copying tool.  It can
                     18: copy locally, to/from another host over any remote shell, or to/from a
                     19: remote rsync daemon.  It offers a large number of options that control
                     20: every aspect of its behavior and permit very flexible specification of the
                     21: set of files to be copied.  It is famous for its delta-transfer algorithm,
                     22: which reduces the amount of data sent over the network by sending only the
                     23: differences between the source files and the existing files in the
                     24: destination.  Rsync is widely used for backups and mirroring and as an
                     25: improved copy command for everyday use.
                     26: 
                     27: %prep
                     28: # Choose one -- setup source only, or setup source + rsync-patches:
                     29: %setup -q -n rsync-%{fullversion}
                     30: #%setup -q -b1 -n rsync-%{fullversion}
                     31: 
                     32: # If you you used "%setup -q -b1", choose the patches you wish to apply:
                     33: #patch -p1 <patches/acls.diff
                     34: #patch -p1 <patches/xattrs.diff
                     35: #patch -p1 <patches/remote-option.diff
                     36: #patch -p1 <patches/db.diff
                     37: 
                     38: # Avoid extra perl dependencies for scripts going into doc dir.
                     39: chmod -x support/*
                     40: 
                     41: %build
                     42: #./prepare-source
                     43: %configure
                     44: 
                     45: make
                     46: 
                     47: %install
                     48: rm -rf $RPM_BUILD_ROOT
                     49: 
                     50: %makeinstall
                     51: 
                     52: mkdir -p $RPM_BUILD_ROOT/etc/xinetd.d
                     53: install -m 644 packaging/lsb/rsync.xinetd $RPM_BUILD_ROOT/etc/xinetd.d/rsync
                     54: 
                     55: #install -p -m 755 support/rsyncdb $RPM_BUILD_ROOT/usr/bin/rsyncdb
                     56: 
                     57: %clean
                     58: rm -rf $RPM_BUILD_ROOT
                     59: 
                     60: %files
                     61: %defattr(-,root,root)
                     62: %doc COPYING NEWS OLDNEWS README support/ tech_report.tex
                     63: %config(noreplace) /etc/xinetd.d/rsync
                     64: %{_prefix}/bin/rsync*
                     65: %{_mandir}/man1/rsync.1*
                     66: %{_mandir}/man5/rsyncd.conf.5*
                     67: 
                     68: %changelog
                     69: * Fri Sep 23 2011 Wayne Davison <wayned@samba.org>
                     70: Released 3.0.9.
                     71: 
                     72: * Fri Mar 21 2008 Wayne Davison <wayned@samba.org>
                     73: Added installation of /etc/xinetd.d/rsync file and some commented-out
                     74: lines that demonstrate how to use the rsync-patches tar file.

FreeBSD-CVSweb <freebsd-cvsweb@FreeBSD.org>