Annotation of embedaddon/thttpd/contrib/redhat-rpm/thttpd.spec, revision 1.1
1.1 ! misho 1: Summary: Throttleable lightweight httpd server
! 2: Name: thttpd
! 3: Version: 2.25b
! 4: Release: 1
! 5: Group: Networking
! 6: URL: http://www.acme.com/software/thttpd
! 7: Source0: http://www.acme.com/software/thttpd/thttpd-%{PACKAGE_VERSION}.tar.gz
! 8: Copyright: distributable (BSD)
! 9: BuildRoot: /tmp/thttpd-root
! 10:
! 11: %description
! 12: Thttpd is a very compact no-frills httpd serving daemon that can handle
! 13: very high loads. While lacking many of the advanced features of
! 14: Apachee, thttpd operates without forking and is extremely efficient in
! 15: memory use. Basic support for cgi scripts, authentication, and ssi is
! 16: provided for. Advanced features include the ability to throttle traffic.
! 17:
! 18: %prep
! 19: %setup
! 20:
! 21: ./configure --prefix=/usr
! 22:
! 23: %build
! 24: make \
! 25: WEBDIR=/home/httpd/html \
! 26: BINDIR=/usr/sbin prefix=/usr \
! 27: CGIBINDIR=/home/httpd/cgi-bin
! 28:
! 29: %install
! 30:
! 31: mkdir -p $RPM_BUILD_ROOT/home/httpd/{cgi-bin,logs}
! 32: mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
! 33: mkdir -p $RPM_BUILD_ROOT/usr/man/man{1,8}
! 34: mkdir -p $RPM_BUILD_ROOT/usr/sbin
! 35: install contrib/redhat-rpm/thttpd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/thttpd
! 36: install contrib/redhat-rpm/thttpd.conf $RPM_BUILD_ROOT/etc/
! 37: make -i prefix=$RPM_BUILD_ROOT/usr install
! 38:
! 39: %pre
! 40:
! 41: grep '^httpd:' /etc/passwd >/dev/null || \
! 42: /usr/sbin/adduser -r httpd
! 43:
! 44: %post
! 45: /sbin/chkconfig --add thttpd
! 46:
! 47: %preun
! 48: /sbin/chkconfig --del thttpd
! 49:
! 50: %clean
! 51: rm -rf $RPM_BUILD_ROOT
! 52:
! 53: %files
! 54: %defattr(-,bin,bin)
! 55: %doc [A-Z]*
! 56: %attr(2755, httpd, httpd) /usr/sbin/makeweb
! 57: /usr/sbin/htpasswd
! 58: /usr/sbin/syslogtocern
! 59: /usr/sbin/thttpd
! 60: %attr(-, httpd, httpd) /home/httpd
! 61: %attr(0755, root, root) /etc/rc.d/init.d/thttpd
! 62: %config /etc/thttpd.conf
! 63: %doc /usr/man/man*/*
! 64:
! 65: %changelog
! 66:
! 67: * Sat Dec 20 2003 Jef Poskanzer <jef@mail.acme.com>
! 68: - Updated to 2.25b
! 69:
! 70: * Mon Oct 27 2003 Jef Poskanzer <jef@mail.acme.com>
! 71: - Updated to 2.25
! 72:
! 73: * Sat Sep 13 2003 Jef Poskanzer <jef@mail.acme.com>
! 74: - Updated to 2.24
! 75:
! 76: * Sat May 25 2002 Jef Poskanzer <jef@mail.acme.com>
! 77: - Updated to 2.23
! 78:
! 79: * Mon Jul 09 2001 Jef Poskanzer <jef@mail.acme.com>
! 80: - Updated to 2.22
! 81:
! 82: * Thu Apr 26 2001 Jef Poskanzer <jef@mail.acme.com>
! 83: - Updated to 2.21c
! 84:
! 85: * Mon Apr 23 2001 Jef Poskanzer <jef@mail.acme.com>
! 86: - Updated to 2.21b
! 87:
! 88: * Mon Oct 02 2000 Jef Poskanzer <jef@mail.acme.com>
! 89: - Updated to 2.21
! 90:
! 91: * Wed Sep 13 2000 Jef Poskanzer <jef@mail.acme.com>
! 92: - Updated to 2.20
! 93:
! 94: * Mon Sep 11 2000 Bennett Todd <bet@rahul.net>
! 95: - added thttpd.conf, took config info out of init script
! 96: - switched to logging in /var/log, used pidfile
! 97:
! 98: * Thu Jun 15 2000 Jef Poskanzer <jef@mail.acme.com>
! 99: - Updated to 2.19
! 100:
! 101: * Thu May 18 2000 Jef Poskanzer <jef@mail.acme.com>
! 102: - Updated to 2.18
! 103:
! 104: * Fri Mar 17 2000 Jef Poskanzer <jef@mail.acme.com>
! 105: - Updated to 2.17
! 106:
! 107: * Mon Feb 28 2000 Jef Poskanzer <jef@mail.acme.com>
! 108: - Updated to 2.16
! 109:
! 110: * Thu Feb 03 2000 Jef Poskanzer <jef@mail.acme.com>
! 111: - Updated to 2.15
! 112:
! 113: * Thu Jan 21 2000 Jef Poskanzer <jef@mail.acme.com>
! 114: - Updated to 2.14
! 115:
! 116: * Thu Jan 6 2000 Jef Poskanzer <jef@mail.acme.com>
! 117: - Updated to 2.13
! 118:
! 119: * Mon Jan 3 2000 Bennett Todd <bet@rahul.net>
! 120: - updated to 2.12, tweaked to move thttpd.init into tarball
! 121:
! 122: * Mon Dec 13 1999 Bennett Todd <bet@mordor.net>
! 123: - Updated to 2.09
! 124:
! 125: * Fri Dec 10 1999 Bennett Todd <bet@mordor.net>
! 126: - Updated to 2.08
! 127:
! 128: * Wed Nov 24 1999 Bennett Todd <bet@mordor.net>
! 129: - updated to 2.06, parameterized Version string in source url
! 130: - changed to use "make install", simplified %files list
! 131:
! 132: * Wed Nov 10 1999 Bennett Todd <bet@mordor.net>
! 133: - Version 2.05, reset release to 1
! 134: - dropped bugfix patch since Jef included that
! 135: - streamlined install
! 136:
! 137: * Sun Jul 25 1999 Bennett Todd <bet@mordor.net>
! 138: - Release 4, added mime type swf
! 139:
! 140: * Mon May 3 1999 Bennett Todd <bet@mordor.net>
! 141: - Release 2, added patch to set cgi-timelimit up to 10 minutes
! 142: fm default 30 seconds
! 143:
! 144: * Wed Feb 10 1999 Bennett Todd <bet@mordor.net>
! 145: - based on 2.00-2, bumped to 2.04, reset release back to 1
! 146: - fixed a couple of broken entries in %install to reference $RPM_BUILD_ROOT
! 147: - simplified %files to populate /usr/doc/... with just [A-Z]* (TODO had gone
! 148: away, this simplification makes it liklier to be trivially portable to
! 149: future releases).
! 150: - added %doc tags for the man pages
! 151:
FreeBSD-CVSweb <freebsd-cvsweb@FreeBSD.org>